워드프레스 아바다 테마에서 'wp_remote_get() failed' 오류가 발생하는 경우

아바다 테마

워드프레스 베스트셀링 테마인 아바다System Status(시스템 상태)에 다음과 같은 오류 메시지가 표시되는 경우가 있습니다.

wp_remote_get() failed. Some theme features may not work. Please contact your hosting provider and make sure that https://build.envato.com/api/ is not blocked.

그리고 특정 플러그인이 설치가 되지 않고 Something went wrong with the plugin API. 이런 문구가 뜨는 경우도 있습니다.

또, 아바다 데모를 설치하려고 Install을 누르면 다음과 같은 오류가 발생하기도 합니다.

We're sorry but the demo data could not be imported. It is most likely due to low PHP configurations on your server. There are two possible solutions.
Solution 1: Import the demo using an alternate method.
Solution 2: Fix the PHP configurations in the System Status that are reported in RED, then use the Reset WordPress Plugin, then reimport.

만약 wp_remote_get() failed 오류 메시지가 시스템 상태에서 표시된다면, 이는 cURL 버전 문제 때문일 가능성이 높다고 합니다.

curl 버그 때문에 이런 문제가 발생할 수 있는데, 이 경우 최신 버전으로 업데이트하면 해결된다고 합니다. 이런 문제가 발생한다면 웹호스팅 업체에 문의하여 cURL 버전을 최신 버전으로 업데이트할 수 있는지 문의해보면 좋을 듯 합니다.

그리고 PHP 버전도 가급적 PHP 7.0이나 7.1을 사용해보시기 바랍니다.

참고로 현재 워드프레스에서 권장하는 PHP 버전은 7.2 이상입니다.

개인적으로 BluehostSiteground에서 아바다를 설치하여 사용하고 있지만 전혀 오류가 없습니다. 하지만 카페2*를 비롯하여 우리나라의 일부 웹호스팅에서 아바다를 설치하여 운영할 때 크고 작은 문제가 발생한다고 호소하는 경우를 간혹 봅니다. PHP 설정값을 높이고 가급적 PHP 버전을 최신 버전으로 적용하면 오류가 줄어들 것 같습니다.

2 thoughts on “워드프레스 아바다 테마에서 'wp_remote_get() failed' 오류가 발생하는 경우”

  1. 저는 블루호스트에서 Avada를 사용하는데 같은 문제가 발생했습니다. 블루호스트에서도 해결을 못하여 워드프레스를 다시 깔고 지금 블루호스트 엔지니어가 updating 중이라는 메시지를 받고 있습니다.

    응답
    • 안녕하세요, 원철연님.

      블로그를 방문해주셔서 감사합니다.

      PHP 버전을 바꾸어서 테스트해보아도 동일한 현상이 발생하나요?

      블루호스트에서 PHP 버전을 변경하는 방법은 다음 글을 참고해보세요:

      https://www.thewordcracker.com/miscellaneous/%EB%B8%94%EB%A3%A8%ED%98%B8%EC%8A%A4%ED%8A%B8%EC%97%90%EC%84%9C-php-%EB%B2%84%EC%A0%84-%EB%B3%80%EA%B2%BD%ED%95%98%EA%B8%B0/

      PHP 7.1, 7.2, 7.3으로 변경하면서 테스트하여 문제를 일으키는지 확인해보면 좋을 듯 합니다.

      그리고 아바다에도 연락하여 이 문제를 상의해볼 수 있을 것 같습니다.

      응답

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드