Let's Encrypt 설치 오류

Centos 6.x에서 Let's Encrypt를 설치하기 위해 다음 문서를 참고하여 설치를 시도해보았습니다.

다음 명령어를 사용하여 Python 버전을 체크해보니 2.6.6으로 표시되네요.

python --version

하지만 Let's Encrypt를 사용하려면 Python 버전이 2.7 이상이어야 한다네요. 그래서 다음 명령을 이용하여 Python 2.7 설치를 시도했습니다.

yum --enablerepo=ius install python27 python27-devel python27-pip python27-setuptools python27-virtualenv -y

하지만 제대로 설치가 되지 않고 이상한 오류가 나오네요.

Error: Package: git-1.7.1-4.el6_7.1.x86_64 (base)
Requires: perl(Error)
Error: Package: git-1.7.1-4.el6_7.1.x86_64 (base)
Requires: perl-Git = 1.7.1-4.el6_7.1
Installing: git2u-perl-Git-2.11.0-1.ius.el6.noarch (ius)
perl-Git = 2.11.0-1.ius.el6
Error: Package: git-1.7.1-4.el6_7.1.x86_64 (base)
Requires: perl-Git = 1.7.1-4.el6_7.1
Available: git2u-perl-Git-2.11.0-1.ius.el6.noarch (ius)
perl-Git = 2.11.0-1.ius.el6
Error: git2u-core conflicts with git-1.7.1-4.el6_7.1.x86_64
Error: Package: git2u-perl-Git-2.11.0-1.ius.el6.noarch (ius)
Requires: perl(Error)
Error: Package: git2u-2.11.0-1.ius.el6.x86_64 (ius)
Requires: perl(Error)
Error: git2u conflicts with git-1.7.1-4.el6_7.1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Package python27-...가 최신 버전이고 이미 설치되어 있다고 나오지만 실제 Python 버전은 2.6.6으로 표시되어 조금 검색을 해보니 cpanel에서 Perl 패키지를 설치하지 못하도록 차단한 것이라고 하네요. 즉, Perl 패키지 설치로 인해 커스터마이징된 패키지의 인터페이스가 방해를 받지 않도록 하기 위한 것(Cpanel blocks installation of any perl packages through yum in order to make sure that nothing interferes with their customized packages)이라고 합니다.

자세한 내용은 stackoverflow 글에서 확인해볼 수 있습니다.

Bluehost VPS에서 StartSSL은 매우 쉽게 설치가 가능했지만 letsencrypt는 호스트 환경에 따라 적용하기가 쉽지가 않네요.

Bluehost 공유 호스팅에서 letsencrypt를 적용하려는 경우에는 Installing a LetsEncrypt SSL on Bluehost 글을 참고해볼 수 있습니다. Bluehost는 그냥 유료 SSL을 구입해서 사용하면 마음 편할 것 같습니다(참고).

참고:

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드