[워드프레스] WPML의 최소 요구 사항

WPML의 최소 요구 사항(Minimum Requirements)

워드프레스에서 다국어를 운영할 때 많이 사용되는 WPML 실행을 위한 최소 요구 사항:

  • WordPress 3.9 이상
  • PHP 5.3 이상. 최소 메모리 제한 128MB ("워드프레스에서 메모리(PHP Memory Limit) 확인 및 늘리기" 참고). 사이트에 필요한 메모리는 컨텐츠, 테마 및 모든 플러그인에 따라 달라집니다. 그리고 최근 WordPress에서는 PHP 5.6 이상을 권장합니다. 그리고 아바다, Enfold와 같은 일부 테마에서는 PHP 5.6 이상이 아니면 제대로 작동하지 않을 수 있습니다.
  • MySQL 5.6 이상
  • 데이터베이스에서 테이블 생성 가능
  • WPML String Translation 사용을 위해 Multibyte String 확장 기능(extension)이 필요합니다.
  • WPML Translation Management에서 XLIFF 파일을 사용하려면 SimpleXML 확장 기능이 필요합니다.

WPML은 구 버전의 PHP와 MySQL에서도 작동할 수 있지만 WPML에서 테스트는 거치지 않았다고 합니다. 요즘은 대부분 PHP 5.4 혹은 PHP 5.5 이상이므로 PHP 버전과 관련해서는 대부분의 사이트에서 문제가 없을 것 같습니다.

참고로 PHP 버전을 체크하려면 FTP를 접속하여 루트 디렉터리에 php_info.php 파일을 하나 만들고 파일에 다음 코드를 추가하도록 합니다. 예를 들어, 루트에 워드프레스가 설치되어 있으면 경로 http://yourdomain.com/php_info.php를 워드프레스 주소 창에 입력한 후에 엔터를 치면 웹호스팅의 자세한 사양을 볼 수 있습니다.

PHP 정보
PHP 정보

고유주소 구조

WPML은 언어 정보를 URL에 추가합니다. WPML은 다음 고유주소 구조에서 테스트되었다고 하네요.

  • 기본값
  • /%year%/%monthnum%/%postname%/

현재 이 블로그에 WPML이 설치되어 있는데, 우려와는 달리 속도 저하가 별로 없습니다. WPML은 아다바, Enfold 등 많은 유료 테마에서는 WPML과의 호환성을 명기할 정기로 인기가 높습니다.

참고:

다국어 워드프레스 솔루션 완벽 가이드: WPML, Polylang, 멀티사이트 비교

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드