워드프레스 권장 사양

워드프레스 PHP 버전

현재 워드프레스 버전(4.6.1) 기준으로 워드프레스를 운영하기 위한 권장 사양은 다음과 같습니다.

  • PHP 버전 7.0 5.6 이상
  • MySQL 버전 5.6 이상 - 또는 - MariaDB 버전 10.0 이상

우리나라에서 가장 많이 사용되고 있는 웹호스팅 업체인 카페24의 경우 현재 PHP 5.5, PHP 7을 지원합니다. 최근 들어 아바다 테마가 PHP 5.5에서도 에러가 발생하는 것을 본 적이 있습니다. Enfold 테마도 PHP 5.5에서는 벅벅 댄다고 호소하는 분도 계십니다.

PHP 7에서 워드프레스를 돌리면 성능이 10% 정도 향상되는 효과가 있다고 합니다. 물론 전혀 효과가 없다는 하는 분도 있지만 PHP 7에서는 확실히 속도 향상 효과가 있는 것 같습니다. 하지만 아직은 PHP 7을 지원하지 않는 플러그인이 제법 있기 때문에 신중하게 고려하여 PHP 7으로 업데이트하는 것이 좋을 듯 합니다.

참고로 현재 이 블로그가 운영 중인 iPage의 경우 PHP 5.6을 지원하지만 PHP 7은 지원하지 않네요. 그리고 Bluehost도 마찬가지로 PHP 5.6을 지원합니다(PHP 7은 미지원). 블루호스트의 경우 저가형은 다소 불안하다는 평이 있으므로 블루호스트를 사용하려는 경우에는 Bluehost VPS 이상을 고려하는 것이 좋을 듯 합니다(참고).

PHP 5.6 이하(5.6 제외)에서 아바다를 설치하여 실행할 경우에 "Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/XXXXX/public_html/wp-content/themes/Avada/includes/class-avada-product-registration.php on line 167" 오류가 발생할 수 있습니다. 이 경우 이 글을 참고해보시기 바랍니다.

참고로 Stockholm(스톡홀름) 테마에서도 이와 비슷한 오류가 발생할 수 있다고 합니다.

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드