최신 PHP 버전을 사용해야 하는 이유

PHP 버전을 업데이트해야 하는 이유

W3Techs에 의하면 전체 웹 사이트의 82%에서 PHP가 사용되고 있다고 합니다. 즉, 10개 사이트 중 8개 사이트가 PHP를 어떤 형태로든 사용하고 있다고 생각할 수 있습니다.

다른 소프트웨어와 마찬가지로 PHP도 릴리스 라이프 사이클이 있습니다. 각 메이저 PHP 릴리스는 보통 출시 후 2년 동안 지원된다고 하네요. 이 기간 동안 정기적으로 버그와 보안 문제가 수정됩니다.

현재 지원되는 버전을 살펴보면:

지원되는 PHP 버전
지원되는 PHP 버전. Source: kinsta.com

현재 PHP 5.6 아래 버전을 사용하는 경우 더 이상 보안이 지원되지 않으므로 패치되지 않은 보안 취약점에 노출될 수 있습니다.

공식 WordPress Stats 페이지에 의하면, (이 글 작성 시점을 기준으로), 60% 이상의 워드프레스 사용자가 아직 PHP 5.4 이하를 사용하고 있다고 합니다. 이러한 통계는 보안적인 측면에서도 좋지 않을 뿐만 아니라 많은 워드프레스 사이트가 PHP 7에서 제공하는 추가적인 성능상의 이익을 이용하지 못하고 있음을 의미합니다.

워드프레스 PHP 통계
워드프레스 PHP 통계. Source: Kinsta.com

보안과 성능, 그리고 지원 측면에서 PHP 버전을 업데이트하는 것이 좋습니다.

CPU 벤치마크 결과 비교
CPU 벤치마크 결과 비교. Source: kinsta.com

이 블로그의 경우 iPage 공유 호스팅을 사용하고 있는데, 현재 PHP 5.6까지 지원되어 PHP 5.6을 사용하고 있습니다(업데이트: 이제 PHP 7.1까지 적용 가능합니다). 메인 블로그는 블루호스트(Bluehost) VPS를 사용 중인데 PHP 7.1까지 지원되고 있습니다. 하지만 일부 플러그인이 PHP 7.1을 지원하지 않아서 PHP 7.0이 사용되고 있습니다.

(저가형 호스팅을 원하는 경우 iPage가 괜찮은 것 같습니다. 보다 안정적인 운영을 원하는 경우 Bluehost VPS가 좋은 선택이 될 수 있습니다. ("해외 웹호스팅 서비스 – 블루호스트(Bluehost) 소개" 참고)

PHP 7이 확실히 PHP 5.6 혹은 이하 버전보다 성능면에서 좋습니다. PHP 7.1에서 더 성능이 향상되었다고 합니다. 아마 시간이 조금 지나면 많은 플러그인에서 PHP 7.1도 지원하지 않을까 생각됩니다.

참고:

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드