PHP MySQL 라이브러리 버전과 MySQL 서버 버전이 다르다는 오류 메시지

Your PHP MySQL library version
최근 해외 웹호스팅인 Bluehost(블루호스트)에서 PHP 7을 적용하기 위해 EasyApache 3 버전을 EasyApache 4로 업그레이드한 후에 phpMyAdmin에 접속하니 아래와 같은 오류 메시지가 표시되었습니다.

PHP MySQL 라이브러리 버전(5.1.73)과 MySQL sever version(5.5.54)이 다릅니다. 이것은 예상하지 못한 문제를 야기할 수 있습니다.

Your PHP MySQL library version 5.1.73 differs from your MySQL server version 5.5.54. This may cause unpredictable behavior.

(오류 메시지에 약간의 오타가 있네요.ㅎㅎ)

이 경고는 온전성 검사(Sanity Check)로써 심각한 것이 아니므로 무시할 수 있다고 하네요(참고).

그러나 올바르게 mysql과 웹 서버를 재시작하고 mysql_upgrade를 실행하면 이와 같은 경고는 발생하지 않는다고 합니다.

Bluehost에서는 공유 호스팅(Shared Hosting)의 경우 현재 PHP 7까지 지원하고 VPS 이상 상품인 경우 PHP 7.1까지 지원합니다.

참고:

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드