[워드프레스] 'Error: PHP is not running' 오류가 발생하는 경우

PHP is not running 오류

웹호스팅 서버에 워드프레스를 설치하려고 시도할 때 다음과 같은 오류가 발생하면서 워드프레스가 설치되지 않는 경우가 있을 수 있습니다.

Error: PHP is not running
WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.

이 경우 두 가지 경우를 의심해볼 수 있을 것 같습니다.

먼저 PHP가 활성화되어 있는지 확인해보시기 바랍니다. FTP에 접속하여 루트 폴더(예: /public_html 폴더, 서버 환경에 따라 다름)에 파일(예: info.php)을 하나 만든 후 다음 코드를 추가하고:

<?php
phpinfo();
?>

그런 다음 www.yourdomain.com/info.php를 브라우저 주소창에 입력한 후에 어떤 화면이 표시되는지 확인하도록 합니다.

만약 PHP 버전이 표시되지 않으면 PHP가 제대로 설치되어 있지 않은 상태입니다. PHP가 활성화되어 있지 않다면 웹호스팅 업체 담당자나 서버 관리자에게 연락하여 워드프레스를 설치할 수 있도록 서버 환경을 구성해줄 것을 요청하면 될 것 같습니다.

만약 PHP 버전이 표시되면 PHP 버전이 너무 낮지 않은지 확인해보도록 합니다. 2017년 3월 현재 워드프레스에서 권장하는 사양은 다음과 같습니다.

PHP 버전 7 이상
MySQL 버전 5.6 이상 또는MariaDB 버전 10.0 이상
HTTPS 지원

얼마 전까지만 해도 PHP 5.6 이상을 권장했는데 이제 PHP 7 이상을 권장하네요. PHP 5.5 이상이 되면 보통 워드프레스 설치에 이상이 없을 것 같습니다. PHP 7을 적용하면 속도 향상을 기대할 수 있기 때문에 가급적 PHP 7을 적용하는 것이 좋을 듯합니다.

현재 이 블로그는 iPage를 사용하고 있는데 PHP 5.6까지 지원하고 있습니다. 시간을 내어 PHP 7을 지원하지 않는지 확인해보아야 하겠습니다. 다른 블로그에서는 Bluehost VPS를 이용하고 있는데 PHP 7.0/PHP 7.1까지 지원하고 있습니다("블루호스트에서 PHP 7 적용하기" 참고).

Leave a Comment

프리미엄 테마 그래픽 동영상 템플릿 무료 다운로드